Forums

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.






Please note that we - the Docear team - will not answer support questions. If you need help, please read the manual, read the FAQ, or discuss here in the forum with other Docear users.

When reporting bugs, or asking questions, please be as specific as possible. Name your operating system (e.g. Windows 7, 64 Bit), your JAVA version (e.g. Java 6, 32 Bit), whether you are using the latest Docear version, and provide step-by-step instructions that allow to reproduce the bug or problem you are reporting. Feel free to upload screenshots.

Due to spammers, we had to activate the registration-only option, i.e. you need to register before you can write in the forum.
Pages: [1]
Author Topic: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
Fred
Newbie
Posts: 2
Post Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: October 28, 2013, 23:34

After I spend some hours this might be useful for others.

Problem: The current PDF Exchange Viewer (2.5.213) keeps crashing under wine 1.4.1 (default) and Debian Wheeze.

Solution:
Installing PDF Exchange Viewer 2.0.42 under wine 1.7.5 (x32) using PlayOnLinux (German Instructions here: http://forum.ubuntuusers.de/topic/kommentare-in-pdf-xchange-viewer-wine/#post-5090667)

But somehow this Installation doesn't show up in the list "choose from installed compatible pdf readers"

We need to define this manually.
In general the viewer is called by

playonlinux --run "NameOfApplication" 

NameOfApplication has to be replaced with the name shown in PlayOnLinux

Here: http://www.playonlinux.com/fr/topic-989-Passing_command_line_arguments_to_Apps.html is described how to use command line arguments. We also need to change the Linux-Path to a Windows-Path, the script in the link above is quite useful for this:

Lets call it 2playOnLinux.sh :

#!/bin/bash
# convert the path into Windows form:
# all credits to http://www.playonlinux.com/fr/topic-989-Passing_command_line_arguments_to_Apps.html
ArgWinePath=`winepath -w "$2"`  
# make sure that nothing is passed to application when no file is given:
FileName=${2:+$ArgWinePath}
# call application with argument:
playonlinux --run "$1" "$FileName"    
exit 0

save this somewhere and make in executable.

Now in Docear:
"Manually define the pdf reader .."

sh*/path/to/script/2playOnLinux*"NameOfApplication"*$FILE

Maybe there is an easier way that I haven't figured out, in this case please add corrections.

Thank you for your feedback. Please note that we - the Docear team - currently do not have the time to answer support questions. However, we encourage all Docear users to help each other.

Fred
Newbie
Posts: 2
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: October 29, 2013, 00:19

Note: somehow this just works with files and paths without whitespaces

Joeran-
[Docear]
Administrator
Posts: 648
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: October 31, 2013, 13:19

thanks a lot for sharing this informatin. i added a link to this post in our manual

Stefan-
[Docear]
Administrator
Posts: 969
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: November 3, 2013, 19:01

Hello Fred,

the current version of "PDF X-Change viewer" (PDFXCV) works for me using WINE on Debian/sid - so I am a little bit puzzled about your report.
Can you tell me more about the crash? On my amd64-system I had to install libwine-cms:i386 in order to correctly start PDFXCV. As far as I know multiarch (letting i386 packages run on amd64 architecture) is also available on Debian wheezy. But you need to enable it.

What I found out just recently: I had these strange displaying bugs with PDFXCV on Linux when switching pages. I could fix it by playing around with PDFXCV's preferences: On the "Perfomance" tab, you should definitely enable the "Use synchrononous mode of page rendering [...]" option. I have not noticed any changes to the rendering speed - but now the PDFs are displayed without any distortion.

Do you sometimes have similar issues? Does changing the preferences work for you too? If so, we will let our users know.

Thanks for your help with playonlinux - I will try it tomorrow! 🙂

Cheers,
Stefan

Stefan Langer
Product Management & Research
Docear - The Academic Literature Suite
http://docear.org

Facebook: https://www.facebook.com/pages/Docear/137985949605902
Google+: https://plus.google.com/106965732112113749959/posts
Twitter: https://twitter.com/Docear_org

Fred
Newbie
Posts: 1
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: November 25, 2013, 18:23

Hi Stefan,
I am not sure what caused the problem, I thought that it was a specific problem of my version of wine, but packages.debian.org suggests that we both have the same version. Multiarch was enabled.

But as wine 1.7.5 solves my problem, I wont spend more time thinking about this 😉

Yes I had some strange displaying bugs which disappeared after scrolling a little bit. Right now it's gone, maybe it depends on the pdf. I'll keep an eye on this and try your suggestion when it appears again.

Fred

Stefan-
[Docear]
Administrator
Posts: 969
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: November 27, 2013, 18:04

Hello Fred,

thanks for letting me know!

Best,
Stefan

Stefan Langer
Product Management & Research
Docear - The Academic Literature Suite
http://docear.org

Facebook: https://www.facebook.com/pages/Docear/137985949605902
Google+: https://plus.google.com/106965732112113749959/posts
Twitter: https://twitter.com/Docear_org

einhander
Beginner
Posts: 25
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: May 23, 2014, 21:07

Hi, You forget about pages.

#!/bin/bash
# convert the path into Windows form:
# all credits to http://www.playonlinux.com/fr/topic-989-Passing_command_line_arguments_to_Apps.html
ArgWinePath=`winepath -w "$4"`  
# make sure that nothing is passed to application when no file is given:
FileName=${4:+$ArgWinePath}
# call application with argument:
playonlinux --run "$1" "$2" "$3" "$FileName"    
exit 0

End then in Docear:

sh*/path/to/script/2playOnLinux*"NameOfApplication"*/A*page=$PAGE*$FILE

Piotr
Newbie
Posts: 5
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: May 24, 2014, 09:44

Hi All,

I have Kubuntu 14.04 LTS 64-bit and I had a problem with PDF XViewer 2.5 (build 211) which was crashing ALWAYS when I saved an annotation (new notes were saved, but the PDF XViewer window was closed). This behaviour was seen also in the previous version of Ubuntu on Wine newer then 1.4. But the 14.04 is not that easy with installing Wine < 1.6
The issue is known to the Wine community:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=23721&iTestingId=65246
The workaround, suggested by the wisdom of the Internet, which worked for me was compiling 32 bit Wine on my own.
http://crunchbang.org/forums/viewtopic.php?id=19240
I did so with Wine 1.7.5 and it\'s OK now.

Piotr

Sadid
Newbie
Posts: 17
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: June 23, 2014, 13:42

I had the same problem with Arch and 64bit version of wine. Just for the record the protable version of PDFXViewr works fine.

Stefan-
[Docear]
Administrator
Posts: 969
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: July 2, 2014, 08:22

Hello Piotr, hello Sadid,

that's very interesting - lately PDFXCV keeps crashing on my computer too.

@Sadid: the portable version seems not to work for me on Debian/sid 64bit. Have you changed anything else, or could you tell me which version of wine you use?

@Piotr: I will try this as soon as I find the time.

Thank you both very much for your help with this. 🙂

Best regards,
Stefan

P.S.: There is a new experimental version of Docear, if you would like to help us testing. 🙂

Stefan Langer
Product Management & Research
Docear - The Academic Literature Suite
http://docear.org

Facebook: https://www.facebook.com/pages/Docear/137985949605902
Google+: https://plus.google.com/106965732112113749959/posts
Twitter: https://twitter.com/Docear_org

Sadid
Newbie
Posts: 17
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: July 2, 2014, 09:14

Hi Stefan,

about the PDFXCV, I'm using:
wine 1.7.21
PDFXCV v2.5 Build(308.2) (recently downloaded)
Arch (3.15.2-1)
and I didn't chagne anything as far as I remember (for protable version).
However this is a known bug in wine

Unfortunately these days I'm not working with Docear (or PDFs in general) so this is not a concrete experiment but I've noticed that both evince and esp. Okular supports standard annotations and probably Highlighting very well. Their support isn't as complete as PDFXCV but they do the job and Docear is able to import the annotations. and as far as I noticed in brief experiement there is no conflict with other standard annotators such as PDFXCV.

Okular has better support of annotations than Evince (there is an attempt in this year Google SoC to bring more annotation features to Evince). It supports sticky notes, simple inline text, different highlights, shapes and free hand drawing (by pressing F6). I think on Linux I'll switch to Okular when I get back on the board 🙂

I think if these are correct you might consider updating your Doc on PDF Apps. Now Okular and evince works with Docear without causing a problem.

Piotr
Newbie
Posts: 5
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: July 2, 2014, 09:50

Hi Stefan,

After a month of using this workaround I must say PDFXCV does crash occasionally. I can't really say when and why, but there are a combinations of circumstances e.g. two papers opened and annotating both of them at the same time, when things go wrong.

Piotr

Stefan-
[Docear]
Administrator
Posts: 969
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: July 2, 2014, 10:12

Hello Piotr,

I have also managed to compile the source of Wine 1.7 and installed it. (It is astonishing that the Debian version of Wine 1.7 does not work as well)

It seems to work for now - even if it will crash now and then it is a vast improvement to crashing on nearly every saving attempt. 🙂

Thanks a lot for your help! I will create a FAQ entry soon. 😀 🙂

Cheers,
Stefan

Stefan Langer
Product Management & Research
Docear - The Academic Literature Suite
http://docear.org

Facebook: https://www.facebook.com/pages/Docear/137985949605902
Google+: https://plus.google.com/106965732112113749959/posts
Twitter: https://twitter.com/Docear_org

Marcos
Newbie
Posts: 1
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: September 17, 2015, 17:34

Hi,

I\'m using Docear on Ubuntu 14.04. After following the instructions specified above to use PDFXCV (with some very minor changes), I get the following error whenever I try to open a pdf:

WARNING: Could not invoke Pdf Reader.

Docear excecuted the following statement on a command line:
\"[docear2pdfxcv /A page=1 \"/home/myuser/sample.pdf\"]\".

The funny thing is that if I execute \"docear2pdfxcv /A page=1 \"/home/myuser/sample.pdf\" myself, it actually works just fine, meaning the docear2pdfxcv command works just fine.

Not sure if the brackets next to the quotation marks (showed in the error message) are there just to delimit the actual command, or if they are indeed part of the executed command, hence the error.

Thanks

einhander
Beginner
Posts: 25
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: September 21, 2015, 14:07

Hi Marcos!
I use this line for PDFXCVIEW:

/home/einhander/bin/PDFXCview.sh*/A*page=$PAGE*$FILE

And script from above.

tpalagyi
Newbie
Posts: 1
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: January 5, 2016, 14:32

Hello,

On Ubuntu 15.10 with PlayOnLinux I simply enter this

playonlinux*--run*PDFXCview*/A*page=$PAGE*`winepath -w "$FILE"`

also see
http://lapraszerelt.blogspot.com/2016/01/started-exploring-docear-httpwww.html?_sm_au_=iMVt1W6B1BQ7cJBb

Best regards,
Tamas

einhander
Beginner
Posts: 25
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 5, 2016, 15:47

For Debian testing I change to:

playonlinux*--run*PDFXCview*/A*page=$PAGE*`wine winepath -w "$FILE"`
einhander
Beginner
Posts: 25
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 5, 2016, 15:47

del

AND
Newbie
Posts: 3
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 10, 2017, 19:36

Hello guys,

I'm new to Linux (Mint 18.1 64bit Cinnamon) but I can find my way around.

I was trying to open these files with PDF X-Change viewer, but it is way too slow through Wine/PoL and I don\'t want to run emulation needlessly. Therefore I decided to install Okular, and for now it seems great - all the markup edits I make in it are opened without problems in PDFXCV.

However, I cannot figure out the command line to use with Okular. I tried going to the console and typing okular, and the program runs alright.

Then I tried using the following command inside Docear:

okular*-i*$PAGE*$FILE

But nothing happens. Okular is not started. Do you guys have any idea how to solve this?

Anyway, I hope Docear will integrate Okular (or another similar PDF reader) directly inside it very soon, so we don\'t have to fiddle with these little things.

EDIT:

Ok, I tried

okular --help-all

and it returns this:

okular --help-all
Usage: okular [Qt-options] [KDE-options] [options] [URL] 

Okular, a universal document viewer

Generic options:
  --help                    Show help about options
  --help-qt                 Show Qt specific options
  --help-kde                Show KDE specific options
  --help-all                Show all options
  --author                  Show author information
  -v, --version             Show version information
  --license                 Show license information
  --                        End of options

Qt options:
  --display <displayname>   Use the X-server display 'displayname'
  --session <sessionId>     Restore the application for the given 'sessionId'
  --cmap                    Causes the application to install a private color
                            map on an 8-bit display
  --ncols <count>           Limits the number of colors allocated in the color
                            cube on an 8-bit display, if the application is
                            using the QApplication::ManyColor color
                            specification
  --nograb                  tells Qt to never grab the mouse or the keyboard
  --dograb                  running under a debugger can cause an implicit
                            -nograb, use -dograb to override
  --sync                    switches to synchronous mode for debugging
  --fn, --font <fontname>   defines the application font
  --bg, --background <color> sets the default background color and an
                            application palette (light and dark shades are
                            calculated)
  --fg, --foreground <color> sets the default foreground color
  --btn, --button <color>   sets the default button color
  --name <name>             sets the application name
  --title <title>           sets the application title (caption)
  --testability             load the testability framework
  --visual TrueColor        forces the application to use a TrueColor visual on
                            an 8-bit display
  --inputstyle <inputstyle> sets XIM (X Input Method) input style. Possible
                            values are onthespot, overthespot, offthespot and
                            root
  --im <XIM server>         set XIM server
  --noxim                   disable XIM
  --reverse                 mirrors the whole layout of widgets
  --stylesheet <file.qss>   applies the Qt stylesheet to the application widgets
  --graphicssystem <system> use a different graphics system instead of the default one, options are raster and opengl (experimental)
  --qmljsdebugger <port>    QML JS debugger information. Application must be
                            built with -DQT_DECLARATIVE_DEBUG for the debugger to be
                            enabled

KDE options:
  --caption <caption>       Use 'caption' as name in the titlebar
  --icon <icon>             Use 'icon' as the application icon
  --config <filename>       Use alternative configuration file
  --nocrashhandler          Disable crash handler, to get core dumps
  --waitforwm               Waits for a WM_NET compatible windowmanager
  --style <style>           sets the application GUI style
  --geometry <geometry>     sets the client geometry of the main widget - see man X for the argument format (usually WidthxHeight+XPos+YPos)

Options:
  -p, --page <number>       Page of the document to be shown
  --presentation            Start the document in presentation mode
  --print                   Start with print dialog
  --unique                  "Unique instance" control
  --noraise                 Not raise window

Arguments:
  URL                       Document to open. Specify '-' to read from stdin.

Anyone has a suggestion how to use these commands to specify a working execution command inside Docear? I'm not good with that so I cannot figure out how exactly to do that.

AND
Newbie
Posts: 1
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 10, 2017, 19:41

BTW How can I see new markup inside Docear? Should I reload it somewhere...? Since it doesn\'t show up on the files I have imported.

AND
Newbie
Posts: 3
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 10, 2017, 19:51

Well guys, I found out how to do it myself 😀

Use this command to use Okular and to have it open on the page of the reference:

okular*-p*$PAGE*$FILE

I still don't know what that $TITLE tag is for and how to use it for the commands. Anyone has any suggestions, please share.

Quote from AND on February 10, 2017, 19:36
Hello guys,

I'm new to Linux (Mint 18.1 64bit Cinnamon) but I can find my way around.

I was trying to open these files with PDF X-Change viewer, but it is way too slow through Wine/PoL and I don\'t want to run emulation needlessly. Therefore I decided to install Okular, and for now it seems great - all the markup edits I make in it are opened without problems in PDFXCV.

However, I cannot figure out the command line to use with Okular. I tried going to the console and typing okular, and the program runs alright.

Then I tried using the following command inside Docear:

okular*-i*$PAGE*$FILE

But nothing happens. Okular is not started. Do you guys have any idea how to solve this?

Anyway, I hope Docear will integrate Okular (or another similar PDF reader) directly inside it very soon, so we don\'t have to fiddle with these little things.

EDIT:

Ok, I tried

okular --help-all

and it returns this:

okular --help-all
Usage: okular [Qt-options] [KDE-options] [options] [URL] 

Okular, a universal document viewer

Generic options:
  --help                    Show help about options
  --help-qt                 Show Qt specific options
  --help-kde                Show KDE specific options
  --help-all                Show all options
  --author                  Show author information
  -v, --version             Show version information
  --license                 Show license information
  --                        End of options

Qt options:
  --display <displayname>   Use the X-server display 'displayname'
  --session <sessionId>     Restore the application for the given 'sessionId'
  --cmap                    Causes the application to install a private color
                            map on an 8-bit display
  --ncols <count>           Limits the number of colors allocated in the color
                            cube on an 8-bit display, if the application is
                            using the QApplication::ManyColor color
                            specification
  --nograb                  tells Qt to never grab the mouse or the keyboard
  --dograb                  running under a debugger can cause an implicit
                            -nograb, use -dograb to override
  --sync                    switches to synchronous mode for debugging
  --fn, --font <fontname>   defines the application font
  --bg, --background <color> sets the default background color and an
                            application palette (light and dark shades are
                            calculated)
  --fg, --foreground <color> sets the default foreground color
  --btn, --button <color>   sets the default button color
  --name <name>             sets the application name
  --title <title>           sets the application title (caption)
  --testability             load the testability framework
  --visual TrueColor        forces the application to use a TrueColor visual on
                            an 8-bit display
  --inputstyle <inputstyle> sets XIM (X Input Method) input style. Possible
                            values are onthespot, overthespot, offthespot and
                            root
  --im <XIM server>         set XIM server
  --noxim                   disable XIM
  --reverse                 mirrors the whole layout of widgets
  --stylesheet <file.qss>   applies the Qt stylesheet to the application widgets
  --graphicssystem <system> use a different graphics system instead of the default one, options are raster and opengl (experimental)
  --qmljsdebugger <port>    QML JS debugger information. Application must be
                            built with -DQT_DECLARATIVE_DEBUG for the debugger to be
                            enabled

KDE options:
  --caption <caption>       Use 'caption' as name in the titlebar
  --icon <icon>             Use 'icon' as the application icon
  --config <filename>       Use alternative configuration file
  --nocrashhandler          Disable crash handler, to get core dumps
  --waitforwm               Waits for a WM_NET compatible windowmanager
  --style <style>           sets the application GUI style
  --geometry <geometry>     sets the client geometry of the main widget - see man X for the argument format (usually WidthxHeight+XPos+YPos)

Options:
  -p, --page <number>       Page of the document to be shown
  --presentation            Start the document in presentation mode
  --print                   Start with print dialog
  --unique                  "Unique instance" control
  --noraise                 Not raise window

Arguments:
  URL                       Document to open. Specify '-' to read from stdin.

Anyone has a suggestion how to use these commands to specify a working execution command inside Docear? I'm not good with that so I cannot figure out how exactly to do that.

AND
Newbie
Posts: 3
Post Re: Hint: Using pdfexchange viewer on Debian Wheeze with PlayOnLinux
on: February 10, 2017, 19:54

Ok, so I figured out how to do this too. Just right-click the PDF file inside Docear, go to PDF -> Import New Annotations.

Quote from AND on February 10, 2017, 19:41
BTW How can I see new markup inside Docear? Should I reload it somewhere...? Since it doesn\'t show up on the files I have imported.

EDIT:

Unfortunatelly, it doesn't work with highlights, only with popup notes. I see that this is in the works (http://www.docear.org/software/add-ons/docears-real-highlights/), any news when this may be released?

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.33.2 ; Page loaded in: 0.131 seconds.