Forums

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.






Please note that we - the Docear team - will not answer support questions. If you need help, please read the manual, read the FAQ, or discuss here in the forum with other Docear users.

When reporting bugs, or asking questions, please be as specific as possible. Name your operating system (e.g. Windows 7, 64 Bit), your JAVA version (e.g. Java 6, 32 Bit), whether you are using the latest Docear version, and provide step-by-step instructions that allow to reproduce the bug or problem you are reporting. Feel free to upload screenshots.

Due to spammers and the new European GDPR initiative, we decided to deactivate user registrations. This means, only users with an existing account will be able to post in the forum. We are sorry for this but see no other way.
Pages: [1]
Author Topic: Docear4Word wont install if .NET newer than 2.0 is already installed
johnplayer-
special
Newbie
Posts: 2
Post Docear4Word wont install if .NET newer than 2.0 is already installed
on: December 20, 2013, 00:05

System: Windows 8.1 Pro 64-bit
Problem: Launching docear4word_setup.exe pops up a dialog box that says "This setup requires the .NET framework 2.0...."

The computer already has a newer version of .NET installed. If you follow the dialog box and try to install .NET v2.0, that installer won't work because the newer version is already present.

How can I install docear4word if I can't get around this?

Thanks,

jps

Thank you for your feedback. Please note that we - the Docear team - currently do not have the time to answer support questions. However, we encourage all Docear users to help each other.

Joeran-
[Docear]
Administrator
Posts: 656
Post Re: Docear4Word wont install if .NET newer than 2.0 is already installed
on: December 20, 2013, 06:07

On my Windows 7 machine I have installed Windows 7 with .NET 4.5 and Docear4Word runs just fine. Actually, I have no idea what the problem could be. But I will ask my colleagues if they have an idea.

Are there any others here who also use Windows 8.1 and have experienced similar problems?

Joeran

johnplayer-
special
Newbie
Posts: 2
Post Re: Docear4Word wont install if .NET newer than 2.0 is already installed
on: December 20, 2013, 22:05

I fixed the problem.

If you have .NET > version 3.5 installed, you need to enable backwards-compatibility in order for it to work:

http://msdn.microsoft.com/en-us/library/hh506443(v=vs.110).aspx

That allows the docear4word installer to skip the installation of .NET v 2.0 and proceed normally.

Jorean, if it worked for you, then you probably already had it enabled. Or you had multiple versions of .NET installed, which apparently is also allowed.

You may want to add a warning to the docear4word installation page to Windows 8 & 8.1 users. Apparently, .NET 4.5 is installed on these machines WITHOUT backwards compatibility turned on by default.

That fixes it, and docear4word works just fine now under Windows 8.1 pro and Word 2013.

jps

Joeran-
[Docear]
Administrator
Posts: 656
Post Re: Docear4Word wont install if .NET newer than 2.0 is already installed
on: December 22, 2013, 13:20

@jps thanks for the information! I added a note to http://www.docear.org/software/add-ons/docear4word/download/

@all: the developer of docear4word also told me this:

After a bit of Googling, I see that this isn’t limited to Docear4Word but any .NET app written for .NET 3.5 or earlier.
The solution is to manually install .NET 3.5 (as your user found 2.0 won’t install directly) from the internet or use this app
http://www.askvg.com/download-microsoft-net-framework-3-5-offline-installer-for-windows-8/
to install it directly from the Windows 8 media.

Mark
Newbie
Posts: 1
Post Re: Docear4Word wont install if .NET newer than 2.0 is already installed
on: October 30, 2014, 18:32

Windows Pro 8.1 64 bit
Control panel / Programs and features / Turn windows features on or off / SOLUTION
Select .NET Framework 3.5 (includes .NET 2.0 and 3.0)

Serious Disclaimer: this solution is provided without any guarantee of suitability to Windows OS.
Platform development is NOT preferential to any other .NET environment than ONLY .NET Framework 4.5 Advanced Services. If you install .NET 3.5, expect file management corruption, security issues, and software conflicts.

Professional Administrator .NET management skills and access are a prerequisite.
Personally, unless I'm in the mood to help out Microsoft, I burn all my redistributables.
I have no .NET management skills.
I am passing on advice from Microsoft support (minus the burning business: Microsoft developers, lost in the eternal rush, are always happy to burn your box, but really do not appreciate your assistance in that department).

Joeran-
[Docear]
Administrator
Posts: 656
Post Re: Docear4Word wont install if .NET newer than 2.0 is already installed
on: June 30, 2019, 11:24

As a summary, this seems to be the easiest fix (https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10)

- Press the ´Windows´ key on your keyboard (this opens the START menu with search box)
- Enter ´Turn Windows Features On or Off´ and select the corresponding entry from the menu
- A new dialog should open, in which you activate the ´.NET 3.5 (includes .NET 2.0 ...)´ option
- Follow the on-screen instructions
- Start the Docear4Word Installer

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.33.2 ; Page loaded in: 0.066 seconds.