Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.

Please note that we - the Docear team - will not answer support questions. If you need help, please read the manual, read the FAQ, or discuss here in the forum with other Docear users.

When reporting bugs, or asking questions, please be as specific as possible. Name your operating system (e.g. Windows 7, 64 Bit), your JAVA version (e.g. Java 6, 32 Bit), whether you are using the latest Docear version, and provide step-by-step instructions that allow to reproduce the bug or problem you are reporting. Feel free to upload screenshots.

Due to spammers and the new European GDPR initiative, we decided to deactivate user registrations. This means, only users with an existing account will be able to post in the forum. We are sorry for this but see no other way.
Pages: [1]
Author Topic: Docear4Word: Incorrect Handling of Split Names?
Posts: 2
Post Docear4Word: Incorrect Handling of Split Names?
on: March 27, 2016, 15:20

I want to refer to a Work authored by an institution or group e.g.

author = {{Scrapy developers}}

As far as I understand this should be correct.

Event though the table in Docear4Work when inserting the reference seems to be correct it does not work. The cite reads "(developers 2016)" in Havard format.

Any ideas on how to fix this?


P.S.: The best example for testingI came across was the following:
author = {{Barnes and Noble, Inc.}}

Thank you for your feedback. Please note that we - the Docear team - currently do not have the time to answer support questions. However, we encourage all Docear users to help each other.

Posts: 20
Post Re: Docear4Word: Incorrect Handling of Split Names?
on: March 28, 2016, 00:17


You can select techreport as the entry type, leave the author field empty and put the institution name in the institution field. This worked for me.

Posts: 1
Post Re: Docear4Word: Incorrect Handling of Split Names?
on: September 17, 2016, 06:57

Josh's answer is probably more general purpose, but the following approaches work also, and may give some hints to the developers. It doesn't seem that this bug would actually be very hard to fix. The problems appear to be due to processing still occurring after the braced terms have initially been passed on unmolested.

For {{Scrapy developers}} and similar entries, just append a lowercase word (followed by a space) to the front of your terms of interest:

author = {{the Scrapy developers}}

(Did you mean to write "Scrapy" or "Scrappy"?)

The Barnes and Noble case can be almost completely solved by passing in:

author = {{Barnes and and Noble Inc.}}

The double "and" convinces Docear4Word that you mean business - that is 'a' business 🙂 . "And" normally indicates a second author which confuses the software, but two adjacent ands break it out of that paradigm. However, this approach itself breaks whenever you run into the "et al." limit for your citation style, such that "Barnes and and Nobel and Thomas Inc." e.g., may not work. "Barnes and and Nobel & Thomas Inc." would work, however, though the result would contain an "and" and an "&". Such ampersand appending can go on indefinitely.

Unfortunately, I have found no way to include a comma in a company or organization name. It's just too strong a marker.

Pages: [1]
Mingle Forum by cartpauj
Version: ; Page loaded in: 0.07 seconds.